The Classic FTB Wiki does not cover Feed The Beast Horizons, since it does not exist in Classic Feed The Beast (Minecraft versions 1.4.7 and earlier).
You may find information about Feed The Beast Horizons on our sister site,

Feed The Beast Horizons is a modpack built on Minecraft 1.6.4, designed to show off new and significantly changed mod. As such, it may not provide a balanced gameplay experience. Due to the RAM requirements, only 64-bit systems can run this pack. This pack does not fall under the scope of this Classic FTB Wiki; for more information, see